BatchPhoto crashes when TIF files are added

Can't figure out how to do a task? Ask here.


I am testing batch photo enterprise for use on a virtual machine for batch recropping and renaming of large batches of tiff files. When executing a very small test batch of around 150 files, the program reports that it "failed..." and all images in the result folder are 1kb in size.

This conversation thread looked similar so I thought I would post it here.

A couple of additional details. I am running the software currently on a virtual machine with tiff files. I can send samples if needed.
During a troubleshooting test, I tried running the same batch of photos through with no edits other than a file format change (jpg) and a file name change (a counter in the format of #####.jpg). This executed successfully. I then ran the crop operation on the converted jpg files and this worked.

I would like to run it on the original tiff files. Any help would be greatly appreciated.

As an aside, speed of processing is an important factor in my operation and I was wondering if there are any opportunities for increasing the processing speed. I have access to a reasonably large number of processing cores and lots of RAM. As well, everything is running off solid state drives. Any assistance would be great!


Posts: 390
Joined: Sat May 16, 2009 11:35 am

Hi Matt,

Thank you for your feedback.

If using the Crop filter please make sure that the cropping rectangle is not partially outside of the image for all the input images. The best way to assure this is to use percentages for the coordinates of the cropping rectangle.

This should work on any number of TIF images. If you have a few particular TIF images that fail to process we can send them to us to investigate at support.

You can get the best speed with multi-core processing which is active by default in the app Settings.
Mike Cosmin Unguru
Product Manager
Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 2 guests