Output thumbnail images appear the same as the input images

Can't figure out how to do a task? Ask here.
Post Reply
Steve
Posts: 4
Joined: Sun Aug 10, 2014 11:38 pm
Contact:

Mon Nov 04, 2019 1:55 am

Since Aug 10, 2014, then updated on Jan 17, 2016, then updated again on Nov 1, 2019 I've been using BatchPhoto Pro and love it. I'm running the most current version v4.4 on my Win 10 desktop PC. Last Friday, when I updated to v4.4 I immediately began having a problem. Nothing I've been able to do corrects the problem. I've rebooted and even un-installed and re-installed the v4.4 software. On your forum I found a several year old post from someone who was experiencing a similar problem to mine where the output images are the same as the input images. Unfortunately, there was no solution given.

My problem specifically, is this later version of BatchPhoto Pro is layering the original colored input image over the B&W output image and that's what I end up seeing on the thumbnails in the various folder viewing programs that I've checked (Win File Explorer, IrfanView, IrfanView Thumbnails, and others). For me this is a big problem because I am working on a multi-year project with over 30,000 scanned images of a 125+ year old monthly magazine from the 1880s and 1890s that I'm archiving and also converting the aged, yellowing pages to B&W and/or grayscale images for OCR. I have to have correctly rendered thumbnail images in all of the hundreds of folders I have to work with, otherwise I will create more problems for myself.

Now, here's the twist, when I open any of the output image files for viewing, they display the correct B&W image. Color thumbnail rendered for a B&W image.

I've captured and annotated seven images and created one short video to give you a storyboard of what I'm experiencing. The 7mb video shows 10 seconds of the output file destination folder so you can see the BatchPhoto output thumbnails first showing for less than a second as B&W, then immediately being overlaid with the original colored version.

Just view these images and video file in numerical order.

http://tcdrr.org/images/Capture-1.JPG
http://tcdrr.org/images/Capture-2.JPG
http://tcdrr.org/images/Capture-3.JPG
http://tcdrr.org/images/Capture-4.JPG
http://tcdrr.org/images/Capture-5.JPG
http://tcdrr.org/images/Capture-6.mp4
http://tcdrr.org/images/Capture-7.JPG
http://tcdrr.org/images/Capture-8.JPG

Any help would be greatly appreciated.

Steve

Cosmin
Posts: 365
Joined: Sat May 16, 2009 11:35 am
Contact:

Mon Nov 04, 2019 1:10 pm

Hi Steve,

Thank you for using BatchPhoto

The File Explorer is using the cached thumbnails and seldomly updates some thumbnails. The images themselves are processed correctly as you can see when you open them.

BatchPhoto does not update the JPG thumbnails, so unless the File Explorer loads the entire images it will show the original unedited thumbnails. This is as it was with all versions of BachPhoto, no changes in the latest version related to thumbnails.
Regards,
Mike Cosmin Unguru
Product Manager

Steve
Posts: 4
Joined: Sun Aug 10, 2014 11:38 pm
Contact:

Mon Nov 04, 2019 8:54 pm

Hi Mike,

Problem solved and it had nothing at all to do with BatchPhoto Pro and everything to do with GIMP. Despite that, I'd like to post on your forum what I figured out to save anyone else the aggravation of tracking down the problem. I would imagine many of your BatchPhoto Pro users also use GIMP, which is a very powerful and free image manipulation program.

Prior to running my images through BatchPhoto Pro's graphic filters, I work on the images in GIMP v2.10 and export them as jpg files. Unbeknownst to me, in this latest version of GIMP, there is a checkbox in GIMP's Export dialog called Save Thumbnail and its default state is checked (see attached image of GIMP Export dialog). I assume its sole purpose is to aggravate people! Because with this option checked, a persistent thumbnail of the original image is embedded in the image forever. And since this thumbnail is not created by the operating system or the viewer application, it cannot be removed by any of the normal methods of refreshing thumbnails. It appears to be retained and passed along through other image programs like BatchPhoto Pro. What we see in my video is the B&W thumb being generated by the OS and then the GIMP original colored thumb being overlayed on top of the OS thumb.

SOLUTION: The only way I found to remove the embedded thumbnail of the original image is to re-export the image from GIMP with the Save Thumbnail option unchecked. You don't have to make any changes to the image, just select Export and make sure the Thumbnail option is unchecked.

Anyway, thank you for your time and I hope I didn't waste too much of it.

Steve
Attachments
Capture.JPG
Capture.JPG (62.47 KiB) Viewed 47 times

Cosmin
Posts: 365
Joined: Sat May 16, 2009 11:35 am
Contact:

Tue Nov 05, 2019 12:03 pm

Hi Steve,

Thank you for the update.
Regards,
Mike Cosmin Unguru
Product Manager

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 10 guests